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Vignetting:   

Image Vignetting is a phenomenon observed in photography which introduces 

some photon energy loss on the periphery of a video or captured image. This 

is translated into a lower color intensity of the pixels of the area where 

the phenomenon appears. Typical vignetted image and its Vignetting corrected 

version are shown below:  

  

The Amount parameter represent the compensation amount, a negative value 

means brighter corner (than the center area) will be compensated as bright 

as the center area while a positive value means darker corner (than the center 

area) will be compensated as bright as the center area. The MidPoint parameter 

is used to control the compensation radius. A smaller value means larger 

corner areas outside of this radius are compensated while a larger value 

means smaller corner areas outside of this radius are compensated. In the 

following images, the Amount of left image is 100, the MidPoint is 0; the 

Amount of right image is 100, the MidPoint is 100:  

  

2.5.3.4 Extended  
Level stretching function is provided for red, green, blue, gray and RGB 

channels separately in the Extended property page. Experienced photographer 

can easily obtain the pleasing effect according to the histogram. The 

operation is easy, dragging the vertical magenta line across the histogram 

and dropping it at the desired location. The level between the two vertical 

lines will be stretched. Note: No matter which channel is selected, auto 

level stretching will analyze the RGB channel of the histogram and calculate 
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the desired level. One point should be kept in mind: Click the Refresh button 

each time the sample is moved, changed the objective or did some parameters 

tuning. Images before and after level stretching are shown below:  

  

2.5.3.5 Misc  
On the Misc property page, there are four groups of parameters can be adjusted: 

Frame Speed Level, Light Frequency, Flip and Mode.  

Frame Speed Level is used to adjust the frame speed of the video. The higher 

the Frame Speed Level, the higher the frame speed and vice versa. ToupView 

will automatically detect the proper Frame Speed Level the first time the 

digital camera runs on the computer. However, if one changes the Frame Speed 

Level manually, ToupView assumes the best Frame Speed Level for the computer 

is selected and will NEVER detect the proper Frame Speed Level automatically.  

  

If the illumination light uses alternative current power supply, horizontal 

stripes may appear on the video for CMOS sensor digital cameras, because CMOS 
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sensor uses electronic rolling shutter. Light Frequency parameter is used to 

prevent this phenomenon.  

Flip can easily mirror the video either vertically or horizontally. Mode 

can switch the video between Polychromatic and Monochromatic.  

2.5.4 Video Stream Format•••  
The ToupView Video Stream Format••• configuration dialog is shown below:  

  
One can change the video format mode, frame rate, color space, compression 

options and so on. Here, we only have the Video Size to check. Check the 

desired one and click OK. This will give one the selected Live Capture Video 

Size. Click Cancel and the selection will be ignored and the dialog will 

close. Clicking Apply will apply the current selection to the Live Capture 

Video but the dialog will remain opened.  

Note: Different devices may have different user interfaces and items. Contact 

the camera supplier for details.  

2.5.5 Still Image Options•••  
Some cameras can produce a still image separate from the capture stream. 

Often the still image is of higher quality or larger size than the images 

produced by the capture stream (Live Capture). The camera may have a button 

that acts as a hardware trigger, or it may support software triggering. A 

camera that supports still images will expose a still image pin.  

To capture a still image, one should first set the size of the image to 

capture. The size is determined by the camera hardware. Here we show an 

example with the UCMOS08000KPA camera.  

Choose Setup->Still Image Options••• will show the following Properties 
dialog:  
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It has 3264*2448, 1600*1200, and 800*600 resolutions. Check the desired one 

and press OK to accept the selection or Cancel to ignore the current 

selection. Click Apply to apply the selection.  

One can check if the device supports Still Image Capture or not by choose 

Setup->View Property•••.  

If the Still Image Capture's Value is Y in the View Property dialog, this 

means that UCMOS08000KPA supports the Still Image Capture operation. The Y 

will enable the menu Setup->Still Image Options••• and the  button on the 

Live Capture Toolbar. The N will disable both of them.  

The other items describe the current Live Capture window size, the size of 

the still image that will be captured. The Live Capture video size can be set 

in Setup->Video Stream Format•••.  
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2.6 Capture  

2.6.1 Capture a Frame  Ctrl+V  

Capture a Frame (shortcut: Ctrl+V or click ) will capture a frame from the  

Live Capture video stream and open it in a new window.  

2.6.2 Capture to Clipboard  Ctrl+C  
Capture to Clipboard (shortcut: Ctrl+C) will copy a frame from the Live 

Capture video stream to the clipboard for further application.  

2.6.3 Time-lapse(Auto Capture)•••  

The Time-lapse (Auto Capture)  command enables the use of the Time-lapse 
(Auto  

Capture) function together with an appropriate time interval. This function 

triggers the images capture at adjustable, regular intervals.   

Auto Capture Procedure  

1. Choose Capture->Time-lapse (Auto Capture)••• or click  button. The Time-

lapse (Auto Capture)••• dialog is shown below:  

  

Input the Directory where one will save all of image files. One can use  

to locate the Directory.  
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In the File section, one can choose Name Format. There are 4 formats, they 

are: yymmddHHMMSS, yyyymmHHMMSS, yy-mm-dd-hh-mm-ss, and yyyy-mm-dd-HH-MM-SS. 

The File Prefix will be attached in front of the Name Format. One can also 

choose File Type in bmp, jpg, png, or tif format. The File Type will be used 

as the file extension. The file extensions jpg, png, and tif have their own 

file Option. The final name in this Time-lapse (Auto Capture) will be TP-

yyyymmHHMMSS.png. This mechanism ensures that the previous image will not be 

overwritten when capturing a new one.  

Click the Option button and the Option dialog corresponding with file 

extension will pop-up for adjustment. For jpg, the Option dialog is:  

  
Image quality  If one save an image in JPEG format (*.jpg), one may 

adjust image quality in the edit box. The values range 
from 0 to 100. Default value: 75.  

Progressive  The default is unchecked.  

Optimize Huffman codes  The default is unchecked.  

Smoothing  The values range between 0 and 100. Default value: 0.  

Save these setting as 
defaults  

When saving a file, the current settings will be saved 
as defaults for the next file save operation.  

For png, the Option dialog is:  
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Interlaced  The default is unchecked.  

Save these setting 
as defaults  

When saving a file, the current settings will be saved 
as defaults for the next file save operation.  

For Tag Image File Format(*.tif, *.tiff), the Option has the following items:   

  

Appended pages  
Determine whether the current image will be saved in 
multiple pages style or not.  

Compressions  

Specifies a method for compressing the composite image 
data.  

For saving a 32‑ bit TIFF file, one can specify that the 
file be saved with predictor compression, but have no 
option to use JPEG compression. Predictor compression 
offers improved compression by rearranging floating point 
values, and works with both LZW and ZIP compression.  

Image quality  

If choose Compressions as "JPEG", the Image quality can 
be adjusted by the slider bar. The values range between 
0 and 100. Default value: 75.  

Save these setting 
as defaults  

When saving a file, the current settings will be saved as 
defaults for the next file save operation.  
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The Time slot (seconds) is used to set the interval of the Auto Capture 

between 2 frames. The minimum is 2s and the maximum is 3600s. Any time beyond 

this range will invoke a warning dialog indicating the correct time interval 

range.  

Check Limit the total times will restrict the total times that the Time-lapse 

(Auto Capture) process occurs. It should be between 1 and 999. Uncheck this 

button, the frame will be captured continuously until one clicks Time-lapse 

(Auto Capture) again to cancel the last Time-lapse (Auto Capture) process.  

If everything is ok, press the OK to begin Time-lapse (Auto Capture).  

2. In the Time-lapse (Auto Capture) process, the dynamic information will be 

shown on the Statusbar. They are:   

  

1) Live Capture camera name;  
2) Process name;   
3) Time slot;   
4) Frames captured and the total frames;  

3. When Time-lapse (Auto Capture)••• is started, the Capture->Time-lapse 

(Auto Capture)••• menu will be checked. One can unchecked it if one want to 

stop the Time-lapse (Auto Capture)••• process. After the Time-lapse (Auto 

Capture)••• process is finished, it will be unchecked to start a new Time-

lapse (Auto Capture)••• process.  

2.6.4 Capture Still Image•••   Ctrl+Z  

Choose Capture->Capture Still Image (shortcut: Ctrl+Z) or click  on the Live 

Capture Toolbar.)  

Some cameras can produce a still image separate from the capture stream, and 

often this still image is of higher quality or larger in size than the images 

produced by the capture stream (Live Capture video). The camera may have a 

button that acts as a hardware trigger, or it may support software triggering. 

A camera that supports still images will expose a still image pin.  

To support the still image capture, ToupView can enumerate the device's 

capability and make Capture Still Image button  enable on the Live Capture 

Toolbar.  

Choose Setup->View Property••• to check if the camera supports still images 

or not.  

In the example below, since the Still Image Capture's value in View Property 

dialog is Y, this means UCMOS080000KPA supports the Still Image Capture.  
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2.6.7 Stop Capture Video  
This menu will be enabled when choose Capture->Start Capture Video••• command 

and begin the video capture   

To stop capturing the video stream, Choose Capture->Stop Capture Video.  
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2.7 Options  

2.7.1Preference•••  Shift+P  
See Process Frame: Options->Preference•••.  

2.7.2 Annotation•••  
See Process Frame: Options->Annotation•••.  

2.7.3 Auto Correction•••  
See Process Frame: Options->Auto Correction•••.   
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2.8 Window  

2.8.1Cascade  
See Process Frame: Window->Cascade.  

2.8.2 Tile  
See Process Frame: Window->Tile.  

2.8.3 Arrange Icons  
See Process Frame: Window->Arrange Icons.   
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2.9 Help  

2.9.1Help Contents  F1  
See Process Frame: Help->Help Contents.  

2.9.2 Show Start Page  
See Process Frame: Help->Show Start Page.  

2.9.3 Check to Update  
See Process Frame: Help->Check to Update.  

2.9.4 About••• See Process 

Frame: Help->About.  
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2.10 Live Capture Toolbar  

  

The Live Capture Toolbar is specially designed for Live Capture window by 
ToupView.  

Its main functions are very useful to perform processes on the Live Capture 
window.  

They are:  

2.10.1 Capture a Frame   
See Live Capture Frame: Capture->Capture a Frame menu.  

2.10.2 Capture Still Image   
See Live Capture Frame: Capture->Capture Still Image menu.  

2.10.3 Time Lapse(Auto Capture)   
See Live Capture Frame: Capture->Time-Lapse(Auto Capture)••• menu.  

2.10.4 Software Power   
See Process Frame: Acquire->Software Power menu.  

2.10.5 Zoom  

Toolbar button . The Live Capture window can sometimes be too large 

to see the whole video for a high resolution camera. In this case, one can 

click arrow button on the right of this Zoom button and select one of the 

items to set the Live Capture window to the proper size. Its dropdown list 

box looks like:  

  

2.10.6 Start  
If the Live Capture window is paused, one can continue the Live Capture 

process by check this button and the Pause button will be enabled.  
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2.10.7 Pause  
If the Live Capture window is running, one can Pause the Live Capture process 

by check this button and the Start button will be enabled.  

2.10.8 Arrow key to move marker or watermark  

 Arrow key to move marker or watermark toolbar button .The Live Capture 

window can display the Video Marker and Video Watermark; one can move them 

with the keyboard arrow keys or its submenus. The Arrow key to move marker 

or watermark’s submenus are  

  

There are two methods to move the Video Marker and Video Watermark  

1. Move the Video Marker and Video Watermark using keyboard arrow keys.  

When this button is checked, one can move the Video Marker and Video Watermark 

to the desired position with the up, down, left and right arrow keys.  

2. Move the Video Marker and Video Watermark using submenus.  

Marker Move to•••  

Choose this menu will display a Move dialog, where one can enter the X and Y 

coordinates of the desired coordinates.  

  

Marker Move to zero  

If the Video Marker was moved, choose this menu will return the Video Marker 

to its original coordinates (0,0).  

Watermark Move to•••  

If the Video Watermark is displayed, this menu will be enabled. Choose this 

menu will display a Move dialog, where one can enter the X and Y coordinates 

of the desired location.  
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Watermark Move to zero  

If the Video Watermark was moved, choose this menu will return it to its 

original coordinates (0,0).  

2.10.9 Arrow key to rotate watermark   

Arrow key to rotate watermark toolbar button .The Live Capture window 

can display the Video Watermark and allow one to rotate it with the keyboard 

arrow keys or submenus. The Arrow key to rotate watermark button’s submenus 

are shown as below:  

 There 

are two methods to move the Video Watermark:  

1. Rotate Video Watermark using keyboard arrow keys:  

When this button is checked, one can rotate the Video Watermark to the desired 

angle with the left and right keyboard arrow keys.  

2. Rotate the Video Watermark with submenus:  

Rotate to•••  

Choose this menu will display a Rotate dialog, where one can enter the angle 

to Rotate the Video Watermark to the desired angle.  

  

Rotate to zero  

If the Video Watermark was rotated, Rotate to zero will be enabled. Choose 

this menu will return the Video Watermark to zero degree.  

2.10.10 Define Software Power Why 

Software Power?  
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Toolbar button . Microscopes with 4X, 10X, 40X, and 100X objectives means 

that it has four different optical powers.  

However, if this microscope is combined with different digital cameras to 

capture the images, the magnification of the captured images is no longer the 

same as the magnification of the objective. Instead, it is represented by the 

Resolution, which is determined by the Software Power of the entire system 

(microscope plus digital camera).  

How to define the Software Power?  

For consistency, a menu called Software Power with some submenus named 4X, 

10X, 40X, and 100X is designed to denote the Resolution. Therefore, these 

Software Powers are actually the system powers (microscope plus digital 

camera), corresponding to the image Resolution.  

When the Software Powers are defined, the Software Powers can be selected in 

ToupView according to the actual microscope objective. After the image has 

been captured, the Resolution can be saved together with the image data.  

If one wants to measure the object's size on the image, ToupView will 

automatically calculate the object's size according to the Resolution and the 

selected Units for further analysis.  

So the first step is to define the Software Power. Different microscope and 

digital camera combinations need to define a set of Software Powers first.  

About the Micro Ruler  

(Note: One need to have a micro ruler with minimum increment of 0.01mm or 10µm 

to Define Software Power. Its overall length is 1mm. It is recommended that 

the stage micrometer or scale used in the calibration should be traceable to 

the National Institute of Standards and Technology (NIST) or a similar 

organization.).  

The steps to Define Software Power are as follows:  

  

Define Software Power  

Step 1: Start the ToupView   
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1. Plug the camera (UCMOS or UHCCD camera for microscope) into the 

trinocular or C-Mount interface of a microscope.  

2. Plug the USB connector to the computer USB port (For USB2.0 cameras, 

be sure to plug it into the correct port, some computers only have a single 

USB2.0 port). 3. Run ToupView.  

4. Put the micro ruler on the microscope’s stage, move the ruler to the field 

center and focus it to see it clearly.  

Step2: Invoke Live Capture and select the default Software Power "Pixel"  

1. Start the Live Capture: One has 3 methods to start Live Capture:  

a). Select Acquire->Live Capture•••.  

b). Click the Live Capture button  on the Live Capture Toolbar and 

select the right camera.  

c). Click on the camera name on the Start Page (Process Frame: Help->Show 

Start Page).  

2. Click the dropdown arrow on the Software Power button  on the  

Live Capture Toolbar to list the Software Power. If no Software Power was 

defined before, there is only the default Pixel item. Select Pixel as the 

Software Power at this time.  

  

Step 3: Define Software Power  
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1. Switch the microscope's objective to the one that wish to define(for 

example 10X at first, or the other 4X, 40X,100X ), focus the micro ruler to 

get a clear image, move the ruler to the Live Capture window center, and let 

it align horizontally with the cross cursor. The Live Capture window should 

look like above:  

2. Click the Define Software Power button  and choose Horizontal Line. 

(The other two modes can be also chosen according to the direction of the 

micro ruler)  

   
The Live Capture window should look like this:  

  

3. Put the cursor at the Start Point (align the cursor vertical line with 

the micro ruler vertical line) and click the mouse button. The point will be 

marked with a small cross. Move the mouse and let align the cursor vertical 

line with the micro ruler vertical line, click the mouse button again, and 

the End Point will be marked. The final screen should look like the following:  

  

4. When the mouse button is released in the above End Point, a Define 

Software Power dialog will be shown below.   
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Here, type 10 in the Software Power edit box. The Actual Length between the 

Start and End point is 650um. After the Actual Length edit box is filled, the 

Resolution will be filled automatically according to the calculation. Now the 

Define Software Power dialog should be   

  

Click OK to end the 10X Software Power definition.  

Step 4: Repeat Step 3 to define the other Software Powers.  

Switch the microscope's objective to the undefined one, repeat Step 3 to 

define the other Software Power. The final Software Power dialog for the 

microscope and camera system should look like below:  

  



ToupView Help  

161  

Here one can Delete••• (After the item is selected, click the Delete••• 

button.) and change the Software Powers list order to the desired one (Select 

the item and click either the Up or the Down button).  

Now the Acquire->Software Power submenus should look like this   

  

The Software Power button on the Live Capture Toolbar should look like this  

   

2.10.11 Gray Calibration  

Toolbar Icon: . Gray Calibration is a useful function to help one to get 

the average gray value of the selected region. Click the toolbar icon, the 

mouse cursor will become a blue cross. Click at the interested rectangle area 

Start Point and then move the mouse cursor to the End Point of the interested 

rectangle area as below:  

  

Click at the End Point, a dialog will open and the rectangle area will be 
blinking.  



ToupView Help  

162  

  

The average gray value of the selected area is shown in the dialog. This 

average gray value can be adjusted by adjust the light intensity or adjust 

the Exposure time or the other camera parameters on the Setup->Video Source 

Property••• menu.  

2.10.12 Auto Focus   

Auto Focus toolbar button   

Auto Focus Prerequisites  

1. Make sure that the ToupView packages and drivers of step motor and 

UCMOS or UHCCD camera is installed correctly.  

2. Plug in all of the devices' cables and turn on the step motor controller 

and microscope light.  

Auto Focus Procedure  

Step 1. Select Acquire->Live Capture or click  and then choose the 

digital camera to open the Live Capture window. One can also open the Live 

Capture window from the Start Page.  

Step 2. Select the proper Software Power from the list  on the Live  

Capture Toolbar and let this Software Power equal to the real microscope's 

objective power to realize the auto-focus function.  

Step 3. Click the button  to start the auto-focus process. During the 
process,  
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one can click the  button again to stop it.  

Step 4. If one switch objective, repeat step 2 and to start the Auto Focus 

again for the new objective.  

Some Important Information about the Auto Focus Process   

1. If Auto focus when start device is checked in the Options->Preference-

>Focus tab, the auto-focus function will be executed after step 1 in the Auto 

Focus Procedure is done.  

2. If Auto focus when switch the software power is checked in the Options-

>Preference->Focus tab, the auto-focus function will be executed after step 

2 in the Auto Focus Procedure is done.  

3. If one wants to do the auto-focus function without changing the real 

microscope's objective, one can run step 3 in the Auto Focus Procedure 

directly to perform the Auto Focus operation.  

2.10.13 Manual Focus  Manual 

Focus toolbar button  Manual 

Focus Prerequisites  

1. Make sure that the ToupView packages, step motor driver and UCMOS or 

UHCCD camera is correctly installed.  

2. Plug in all of the devices' cables and Turn on the step motor controller 

and microscope power.  

Manual Focus Procedure  

1. Select Acquire->Live Capture or click  and then choose the digital 

camera to open the Live Capture window. One can also open the Live Capture 

window from the Start Page.  

2. Click the button  to start the manual focus dialog as shown below:  
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The two left buttons  in this dialog represent coarse focus  

(keyboard shortcuts: Ctrl/Shift +PageUp, Ctrl/Shift +PageDown), and the two  

right buttons  represent fine focus (keyboard shortcuts: PageUp, 

PageDown). Click Settings… button will open Options->Preference->Focus tab.  

3. To stop the manual focus process, please click (keyboard shortcut:  

Delete).  

2.10.14 Auto Fusion   

Image Fusion toolbar button:    

Function Prerequisites  

1. Make sure the ToupView packages, drivers of step motor, and UCMOS or 

UHCCD cameras are correctly installed.  

2. Plug in all of the devices' cables and turn on the step motor controller 

and microscope light.  

Image Fusion Procedure   

Step 1. Click the Live Capture Toolbar button  and the following dialog 

will be shown:  

  

The Step Number and Step Length are set according to the sample’s thickness 

and richness in detail as well as the object’s magnification.  

Step 2. Click the Start button and the application will capture images to do 

the fusion according to the Step Number and Step Length. When the capture is 

finished, the object stage will reset to its original z position.  

 and  
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Step 3. Click the Test Run button and the system will do a dummy run to see 

if the Step Number and Step Length are correct. During this process, the 

image capture and fusion will not be processed. When the operation is 

finished, the object stage will reset to its original position.  

Step 4. During the Fusion calculation and Test Run process, the Cancel button 

can be clicked at any time to cancel this operation. However, the object 

stage will not be able to return to its original position under this 

circumstance.  

Step 5. The progress bar will run two times after clicking the Start button: 

the first time for image capture, and the second for image fusion. However, 

in the Test Run, it will run only once.  

Step 6. The whole image fusion process is illustrated as the movie in the 

bottom right corner of the dialog.  

Image Fusion Key Points for Reference   

1. Before doing the Image Fusion, move the object stage until it reaches 

the place closest to the objective, and make sure there is at least one clear 

region in the field of view.  

2. Set the Step Number and Step Length according to the sample focal depth 

as well as the objective power.  

3. Click the Test Run button, and a test run will launch for one to examine 
if the Step Number and Step Length are proper.  

4. After the Test Run, the system will return to its original position 

automatically. If the Step Number and Step Length are satisfactory, click the 

Start button to do the Image Fusion; otherwise, re-set the Step Number and 

Step Length (step 2) in Image Fusion Procedure.  

2.10.15 Manual Fusion  

Manual Fusion toolbar button   

Function Prerequisites: use step motor to move the stage  

1. Make sure that the ToupView packages, step motor drivers, and UCMOS or 

UHCCD camera are correctly installed.  

2. Plug in all of the devices' cables and turn on the step motor controller 

and the microscope's light.  

Function Prerequisites: to move the stage manually  

No prerequisites.  

Image Fusion Procedure without Autofocus Controller (default)  
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Step 1. Click the Live Capture Toolbar button  and the following dialog 

will pop-up:  

  

Step 2. Use the coarse and fine focus knobs to move the sample stage up and 

down, in order to find the different positions where the clearest regions of 

the whole sample can be seen.  

Step 3. Click the Capture button to capture an image into the image list 

which will be used to do the fusion.  

Step 4. Unless there is more than one image being captured, the Fusion and 

Clear buttons will not be enabled.  

Step 5. If enough images are captured, click the Fusion button to do the 

image fusion. If the captured images are not satisfactory, one can click the 

Clear button to clear the captured images, and capture new images.  

Step 6. If Fusion is clicked, please wait for some time to get the fusion 
result.  

Manual Fusion Key Points for Reference   

1. Use the coarse and fine focus knobs to move the sample stage up and down.  

2. Clicking the Capture button will capture the current image into the image 
fusion list.  

3. Repeat steps 1-3 until there are enough images.  

4. Click the Fusion button will start image fusion. Wait for some time and a 
fantastic fusion result will be displayed in a new window.  

2.10.16 Measure  
If one wish to perform the measure in units other than Pixels, the 

corresponding Software Power must be defined (if not defined) or chosen (if 

defined). See the Live Capture Toolbar: Define Software Power button for 

details.  

Step 1. If the used microscope's objective is 40X, then adjust Software Power 

from the Software Power combo box  to 40X.   



ToupView Help  

167  

Step 2. Click the Measure button  and select Length Measurement from the 

drop-down menu as shown below:  

  

There should be a big and a small alignment cursor as shown below (one can 

set their properties in the Measurement Setting••• menu shown above).  

Step 3. Click the Start Point, move the mouse, and click the End Point.  

  

After the mouse button is released, a dialog listing the measurement results 

will automatically pop-up as shown below:  

  

Step 4. The Angle Measurement is the same as the Length measurement, but need 

to click three points.  

Step 5. One can also perform Batch Measurement on the Live Capture window. 

The Batch Measurement menu is shown below, it includes Length Measurement, 

Angle Measurement and View Result•••.  
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Take Length Measurement for example  

a).Choose the Batch Measurement->Length Measurement  

b).Click the Start Point, move the mouse, and click the second point (End 
Point).  

  

After the mouse button is released, the first Length Measurement is finished  

c).Repeat a) and b) again will end another Length Measurement.  

…  

d)Choose Batch Measurement->View Results•••, a dialog called Measurement 

Result shown below:  

 Click 

Process>, 3 submenus will be shown as   
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Export to Excel  

Choose this menu will export the Batch Measurement to an Excel sheet.  

  

Export to Text•••  

Choose this menu will export the Batch Measurement to a Text file.  

Average•••  

Choose this menu will give the average result of the Batch Measurement as 
below  

  
2.10.17 ROI (Region of Interest)  

Toolbar Icon:  ROI means region of interest. This utility function is 

used to help focus on the region of interest by shrinking the Live Capture 

window to the defined ROI size. Click this icon will pop-up a menu as below:  

  

ROI by Rectangle：Choose this menu, the mouse cursor will become a blue cross. 

Click on the Start Point of ROI, and then move the mouse cursor to the End 

Point of ROI as below:  
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Click the mouse again, the Live Capture window will shrink to the selected 

ROI as below:  

  

ROI by Dialog••• Choose this menu, a dialog will pop-up as below:  

  

In this dialog, the shrink ratio and the coordinates of the start point (upper 

left point) of the ROI can be manually input to help to define the ROI 

precisely.  

ROI Clear: Choose this menu will clear all previously defined ROI and reset 

the Live Capture window to its original size.   
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2.11 Live Capture Statusbar  

  

1. The camera name.  

2. The Software Power and its resolution.  

3. The current horizontal or vertical ruler’s length between two numbers in 
the Live Capture window.  

Double click this icon will invoke a Process Frame: Options->Annotation••• -

>Length tab and one can check the Unit or define the new Unit.  

Click this icon with the right mouse button will pop-up the Unit Context 

Menu. Here, the different Unit can be selected with ease. One can also 

Customize the Unit by choose Customize•••menu, this will be the same as the 

double clicks operation.  
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4. ROI: Region of interest. 100% means the whole video is displayed. See Live 
Capture Frame: Live Capture Toolbar->ROI for details.  

5. Marker’s position and Water Marker position and rotations.   

See Process Frame: Acquire->Video Marker•••,   

     Acquire->Video Watermark•••,   

     Live Capture Frame: Live Capture Toolbar-> Arrow key to move marker or 

watermark,   

     Live Capture Frame: Live Capture Toolbar->Arrow key to rotate watermark 

for details.   
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3 Browser Frame  

3.1 Browser Frame Introduction  
With ToupView’s Browser Frame, files and images can be browsed, sorted, 

managed, manipulated, and shared. Different tools and panes can be combined 

to perform sophisticated searching and filtering operations, and view 

thumbnail previews of the images.   

The Browser Frame is fully customizable. It can be moved, resized, hidden, 

docked, or closed. One can also stack the panes together for easy reference 

and accessibility, and to maximize screen space.  

  

ToupView’s Browser Frame consists of the following panes:  

1. Browser Frame Menu.  
2. Start Frame Toolbar: See Start Frame: Start Frame Toolbar.  
3. Browse Frame Toolbar: See Browser Frame: Browser Frame Toolbar.  
4. Folder: This pane displays the computer directory structure, much like the 

directory tree in Windows Explorer. One can use the Folder pane to browse 

through the folders and display their contents in the File List pane. One 

can also display the contents of multiple folders in the File List Pane by 
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clicking the Easy Select box opposite each folder on the left side of the 

pane.  

5. File List Pane: File List Pane: This pane displays the images in the 
selected folder. The File List Pane is always visible, and cannot be hidden 

or closed. One can customize the File List Pane by changing either the way 

the files are displayed or the size of the thumbnails.   
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3.2 File  

3.2.1Open Image•••   Ctrl+O  
See Process Frame: File->Open Image•••  

3.2.2 Open Video•••  
See Process Frame: File->Open Video•••.  

3.2.3 Paste as New File•••  
See Process Frame: File->Paste as New File•••.  

3.2.4 Print Setup•••  
See Process Frame: File->Print Setup•••.  

3.2.5 Recent File  
See Process Frame: File->Recent File.  

3.2.6 Exit  
See Process Frame: File->Exit.   
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3.3 Acquire  

3.3.1 Live Capture 
See Process Frame: Acquire->Live Capture.  

3.3.2 Software Power  
See Process Frame: Acquire->Software Power.  

3.3.3 Manage Software Power•••  Ctrl+M  
See Process Frame: Acquire->Manage Software Power•••.  

3.3.4 Video Marker•••  
See Process Frame: Acquire->Video Marker•••.  

3.3.5 Video Overlay Text•••   Ctrl+D  
See Process Frame: Acquire->Video Overlay Text•••.  

3.3.6 Video Watermark•••    Ctrl+W  
See Process Frame: Acquire->Video Watermark•••.  

3.3.7 Auto Maximum Size•••  Ctrl+U  
See Process Frame: Acquire->Auto Maximum Size•••.  

3.3.8 Capture with Marker and Watermark   Ctrl+F  
See Process Frame: Acquire->Capture with Marker and Watermark.  

3.3.9 Twain:Select Device•••  
See Process Frame: Acquire->Twain:Select Device•••.  

3.3.10 Twain:Acquire•••  
See Process Frame: Acquire->Twain:Acquire•••.  

  

3.4 Edit  

3.4.1Cut   Ctrl+X  

Toolbar button . One can Cut files and Paste them into another folder in 
the  

Browser's File List Pane using ToupView. To Cut files, do the following:  

Select one or more files and choose Edit ->Cut (shortcut: Ctrl+X).  
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3.4.2 Copy   Ctrl+C  
One can Copy files and Paste them into another folder using ToupView. To Copy 

files:  

In the Browser's File List Pane, select one or more files and choose Edit-

>Copy or click  (shortcut: Ctrl+C).  

3.4.3 Paste   Ctrl+V  

After copying or cutting file(s), one can Paste  them into a folder using 

ToupView. To Paste a file(s) in ToupView:  

Select the file(s) in the Browser's File List Pane and navigate to the proper 

folder in the Folders pane. Then select Edit->Paste (shortcut: Ctrl+V).  

3.4.4 Paste Shortcut  
After copying or cutting files, one can Paste Shortcut into a folder using 
ToupView.  

To Paste the Shortcut of a file in ToupView:  

Select the file(s) in the Browser's File List Pane and navigate to the proper 

folder in the Folders pane. Then select Edit->Paste Shortcut.  

3.4.5 Select All   Ctrl+A  
When organizing files and folders, one can select all of the files.  

To Select All files in the current directory, click Edit->Select All 
(shortcut:  

Ctrl+A).  

3.4.6 Inverse Selection  
When organizing files, one can invert a selection in order to select all of 

the files that were not previously selected.   

To perform this operation, click Edit->Invert Selection.  

3.4.7 Delete File   Delete  

Delete File toolbar button . One can also Delete one or more files or 

folders from the Browser Window. To remove a file or folder from the Browser 

Window:  

Select one or more files or folders.   

Choose Edit->Delete File or click  (shortcut: Delete button). A Confirm 
File  

Delete dialog will pop-up. In the Confirm File Delete dialog, click Yes to 

move the file to the desktop recycle bin, or click No to cancel.  
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3.4.8 Pause   Pause  

Pause toolbar button . When Browser is shown or when the directory in the  

Folders is changed, ToupView will automatically begin to cache image 

thumbnails in the database. When thumbnails are cached, they are recalled 

from the database instead of generated from the file each time start ToupView 

and choose the Browser menu. This can improve system performance.  

Click this button  and ToupView will Pause caching image thumbnails in the 

File List Pane.  

Click this button again to continue caching image thumbnails in the File List 

Pane.   
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3.5 View  

3.5.1File Bar  
The Folders Pane includes a folder tree of all of the folders in the computer, 

similar to Windows Explorer. One can view the contents of the folders in the 

File List Pane on the right side of the Browser interface.  

One can add, delete, or rename files and folders in the Folders Pane. One can 

also drag files and folders to new locations in the pane.  

To show/hide the File Bar : Check View->File Bar or click  icon on the  

Browser Frame Toolbar.  

3.5.2 Tool Box   Ctrl+T See 

Process Frame: View->Tool Box  

3.5.3 Annotation Manager  
See Process Frame: View->Annotation Manager  

3.5.4 Sort  

Sort toolbar button . In the Browser window, one can sort files according 

to different file properties in order to quickly organize images, find 

specific files, and create a range of files with similar attributes for easy 

selection.  

To Sort items in the File List:  

3.5.4.1 Sort->Sort by Names  

Sort the image files in order of names.  

3.5.4.2 Sort->Sort by Type  

Sort the image files in order of type.  

3.5.4.3 Sort->Sort by Size   

Sort the image files in order of size.  

3.5.4.4 Sort->Sort by Width  

Sort the image files in order of width.  

3.5.4.5 Sort->Sort by Height  

Sort the image files in order of height.  

3.5.4.6 Sort->Forward  

Sort the image files in order of the Forward mode (i.e. 1,2,3,4).  

3.5.4.7 Sort->Reverse  
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Sort the image files in order of the Reverse mode (i.e. 4,3,2,1).  

The Sort settings are saved until they are changed. For example, if one sort 

images in the File List Pane according to the Type, the images will remain 

sorted according to Type until the Sort settings are changed.  

3.5.5 Icons  

Icons toolbar button . One can select different view modes in the File 
List  

Pane. The Thumbnail view mode displays small images previews.  

Then select one of the following:  

3.5.5.1 Icon->Large Icons  

Show the image files in Large Icon format.  

3.5.5.2 Icon->Small Icons  

Show the image files in Small Icon format.  

3.5.6 Refresh  

Refresh toolbar button:  If the files in the Folders are altered outside 
of  

ToupView, after switch back to ToupView, one can Refresh the image files in 

the current directory to update the Thumbnails.  

Press  (shortcut: F5) on the Browser Frame Toolbar to Refresh the image 
files.  
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3.6 Options  

3.6.1Preference•••  Shift+P  
See Process Frame: Options->Preference•••.  

3.6.2 Annotation•••  
See Process Frame: Options->Annotation•••.  

3.6.3 Auto Correction•••  
See Process Frame: Options->Auto Correction•••.   
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3.7 Window  

3.7.1Cascade  
See Process Frame: Window->Cascade.  

3.7.2 Tile  
See Process Frame: Window->Tile.  

3.7.3 Arrange Icons  
See Process Frame: Window->Arrange Icons.   
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3.8 Help  

3.8.1Help Contents  F1  
See Process Frame: Help->Help Contents.  

3.8.2 Show Start Page  
See Process Frame: Help->Show Start Page.  

3.8.3 Check to Update  
See Process Frame: Help->Check to Update.  

3.8.4 About••• See Process 

Frame: Help->About.  
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3.9 Browser Frame Toolbar  

ToupView’s Browser Frame Toolbar is shown below. To invoke the Browser, choose 

View->Browser (shortcut Ctrl+B).  

  

Each icon's function is described below:  

1. File Bar: Show/Hide the Browser Folders. See Browser Frame: View->File 
Bar for details.  

2. Delete File: Send the selected file(s) to the Recycle Bin. See Browser 
Frame: Edit->Delete File for details.  

3. Refresh: Reload images. See Browser Frame: View->Refresh for details.  
4. Icons: Select thumbnail mode. See Browser Frame: View->Icons for 

details. 5. Sort: Arrange images by name, type, size, width, height, 

or by alphabetical order. See Browser Frame: View->Sort for details. 

6. Pause: Pause loading the images from the current directory. . See 

Browser Frame: Edit->Pause for details.  

7. Property: Display the selected image properties. When a file is 

selected, this button will be enable.Click it will pop-up XXX Properties 

dialog as below. Here, XXX is the selected file name.  
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3.10 Browser Frame Statusbar  

3.10.1 Selection No  
When no file is selected in the File List Pane in the current directory, the 

Statusbar will display the information about the selected file location and 

the whole image files in the current directory as shown below:  

  

3.10.2 Single Selection   
When a single file is selected in the File List Pane in the current directory, 

the Statusbar will display the selected file information as shown below:  
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1. The selected file location in number and the total file number listed in 
the current selected directory, here, they are 8 and 58 respectively.  

2. The selected file name.  

3. The selected file color bits and its width and height.  

Drag the selected file out of thr Browser will open it in a Image window  

3.10.3 Multiple Selections   
When multiple files are selected in the File List Pane in the current 

directory, the Statusbar will display the information of the multiple selected 

file properties as shown below:   

  

1. The number of selected files and the total number of files in the 

current directory.  

2. If the selected files' color bits and dimensions are the same, they 

will be displayed; otherwise, nothing will be displayed.  

Use   
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4 Start Frame  

4.1 Start Frame Introduction  
The Start Frame includes:   

1. Start Frame Menu.   

2. Start Frame Toolbar: See Start Frame: Start Frame Toolbar.  

3. Start Page: Here, the user can launch the:  

Open Image File: Click on the Recent Files list can open it in an Image 

Window. See Process Frame: File->Recent Files, Options->Preference->Misc-> 

Privacy for more information.  

Browser Frame: Click on the Browser Folder to browse the images in the 

selected directory.  

Live Capture: Click on the Camera name to start the Live Capture very quickly.  

See Process Frame: Help->Show Start Page for details.  
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4.2 File  

4.2.1Open Image•••   Ctrl+O  
See Process Frame: File->Open Image•••.  

4.2.2 Open Video•••  
See Process Frame: File->Open Video•••.  

4.2.3 Paste as New File•••  
See Process Frame: File->Paste as New File•••.  

4.2.4 Print Setup•••  
See Process Frame: File->Print Setup•••.  

4.2.5 Recent File  
See Process Frame: File->Recent File.  

4.2.6 Exit  
See Process Frame: File->Exit.   
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4.3 Acquire  

4.3.1Live Capture 
See Process Frame: Acquire->Live Capture.  

4.3.2 Software Power  
See Process Frame: Acquire->Software Power.  

4.3.3 Manage Software Power•••  Ctrl+M  
See Process Frame: Acquire->Manage Software Power•••.  

4.3.4 Video Marker•••  
See Process Frame: Acquire->Video Marker•••.  

4.3.5 Video Overlay Text•••  Ctrl+D  
See Process Frame: Acquire->Video Overlay Text•••.  

4.3.6 Video Watermark•••  Ctrl+W  
See Process Frame: Acquire->Video Watermark•••.  

4.3.7 Auto Maximum Size•••  Ctrl+U  
See Process Frame: Acquire->Auto Maximum Size•••.  

4.3.8 Capture with Marker and Watermark   Ctrl+F  
See Process Frame: Acquire->Capture with Marker and Watermark.  
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4.3.9 Twain:Select Device•••  
See Process Frame: Acquire->Twain:Select Device•••.  

4.3.10 Twain:Acquire•••  
See Process Frame: Acquire->Twain:Acquire•••.  

4.4 View  

4.4.1Browser   Ctrl+B  
See Process Frame: View->Browser.  

4.4.2 Tool Box   Ctrl+T  
See Process Frame: View->Tool Box.  

4.4.3 Annotation Manager See Process 

Frame: View->Annotation Manager.   
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4.5 Options  

4.5.1Preference•••  Shift+P  
See Process Frame: Options->Preference•••.  

4.5.2 Annotation•••  
See Process Frame: Options->Annotation•••.  

4.5.3 Auto Correction•••  
See Process Frame: Options->Auto Correction•••.   
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4.6 Window  

4.6.1Cascade  
See Process Frame: Window->Cascade  

4.6.2 Tile  
See Process Frame: Window->Tile  

4.6.3 Arrange Icons  
See Process Frame: Window->Arrange Icons   
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4.7 Help  

4.7.1Help Contents   F1  
See Process Frame: Help->Help Contents  

4.7.2 Show Start Page  
See Process Frame: Help->Show Start Page  

4.7.3 Check to Update  
See Process Frame: Help->Check to Update  

4.7.4 About•••  
See Process Frame: Help->About  
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4.8 Start Frame Toolbar  

  

1. Open: Open an image file. See Process Frame: File->Open Image•••.  

2. Save: Save image file. See Process Frame: File->Save.  

3. Cut: Cut the selected Annotation objects. See Process Frame: Edit->Cut.  

4. Copy: Copy the selected Annotation objects or rectangular area image to 

clipboard. See Process Frame: Edit->Copy.  

5. Paste: Paste the Annotation objects above the Background layer. See 

Process Frame: Edit->Paste.  

6. Browser: Show/Hide Browser window, see Process Frame: View->Browser for 

details.  

7. Tool Box: Show/Hide Tool Box. See Process Frame: Edit->Tool Box.  

8. Live Capture: Start Live Capture. See Process Frame: Acquire->Live 
Capture.  

9. Twain:Select Device: See Acquire->Twain: Select Device•••.  

10. Twain:Acquire: See Process Frame: Acquire->Twain: Acquire•••.  

  


